Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 10, 2025 - 11:30 UTC
Scheduled
Dear Customer,
We would like to inform you about an upcoming planned maintenance activity scheduled for Tribe Reporting storage (also known as Tribe SFTP).
Maintenance Schedule: Start: 2025-09-10 11:30:00 UTC End: 2025-09-10 12:00:00 UTC
This maintenance is part of Tribe's ongoing commitment to continuously improve the stability and performance of our services. Kindly note that during the maintenance window, Tribe Reporting storage (also known as Tribe SFTP) will be not accessible.
Please be assured that access will be fully restored immediately after the maintenance is completed. No action is required on your side.
If you have any questions or concerns, please feel free to contact us through the Tribe Support Centre ticketing system: https://support.tribepayments.com
Thank you for your understanding. Tribe Operations Team
Posted Sep 09, 2025 - 13:40 UTC
This scheduled maintenance affected: Issuer Processing (Tribe Hub) and Acquirer Processing (Tribe Hub).