After monitoring, we can confirm that the previously identified service disruption has been resolved, and all services are operating normally.
Affected customers have been informed separately by our team where applicable. We continue to monitor the environment to ensure service stability.
We apologize for the inconvenience caused and thank you for your patience and understanding.
Kind regards, Tribe Operations Team
Posted May 06, 2026 - 14:41 UTC
Monitoring
Dear customers,
Please be informed that the previously identified service disruption seems to have been resolved, and services are operating normally again.
Our team is currently monitoring the situation closely and investigating the root cause of the incident. Affected clients will be informed separately by our team where applicable.
We apologize for the inconvenience caused and appreciate your patience and understanding.
Kind regards, Tribe Operations Team
Posted May 06, 2026 - 02:32 UTC
Investigating
Dear customers,
Please be informed that we are currently experiencing a service interruption affecting some of our services. Our team is actively investigating the issue and working to restore normal operations as quickly as possible.
We apologize for the inconvenience and appreciate your patience while we resolve the situation. Further updates will be shared as more information becomes available.
Kind regards, Tribe Operations Team
Posted May 06, 2026 - 01:45 UTC
This incident affected: Bank Connect (Bank Payments processing), Issuer Processing (Card Payments processing, Bank Payments processing, API), Acquirer Processing (Payments processing, API), Fraud & Risk monitoring (Event processing, API), and Digital Banking (Payments processing, API).