Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 03, 2025 - 01:00 UTC
Scheduled
Dear Customer,
We would like to inform you about upcoming planned maintenance events scheduled by Discover.
Maintenance Schedule: Start: 2025-07-03 01:00:00 UTC End: 2025-07-03 19:00:00 UTC
Expected Impact: ISAC-ISS: Authorisations may be affected during the maintenance window. ISAC-ACQ: Clearing and settlement of Acquiring transactions may experience unexpected delays.
If you have any questions or concerns, please feel free to contact us through the Tribe Support Centre ticketing system: https://support.tribepayments.com
Thank you for your understanding.
Tribe Operations Team
Posted Jun 30, 2025 - 05:47 UTC
This scheduled maintenance affects: Issuer Processing (Card Payments processing) and Acquirer Processing (Payments processing).