Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 14, 2026 - 10:00 UTC
Scheduled
Dear Customer,
We would like to inform you of routine infrastructure upgrades to Entersekt's 3DS ACS production environment.
Maintenance Schedule: Start: 2026-07-14 10:00:00 UTC End: 2026-07-14 12:00:00 UTC
While no service disruption is expected during this maintenance window, we are sharing this notice in advance. Should any unexpected issues arise, our monitoring systems and operational teams will work to identify and address them promptly.
If you have any questions or concerns, please contact us through the Tribe Support Centre ticketing system: https://support.tribepayments.com
Thank you for your understanding. Tribe Operations Team
Posted Jul 13, 2026 - 08:17 UTC
This scheduled maintenance affected: 3D Secure (Access Control Server (ACS)) and Issuer Processing (Card Payments processing).