Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 03, 2025 - 19:00 UTC
Scheduled
Dear Customer,
We would like to inform you about an upcoming planned maintenance event scheduled by the JCB network.
Maintenance Schedule: Start: 2025-09-03 19:00:00 UTC End: 2025-09-03 19:40:00 UTC
Expected Impact: ISAC-ACQ: The online authorization service will be temporarily unavailable during the maintenance window.
Specifically: The JCB Settlement System will not verify Interchange Files or send Activity/Erroneous Data Reports during this period. Interchange Files will be verified after the replacement of network equipment is completed.
Please note that while a brief service disruption is expected, the maintenance is part of a planned and controlled operation conducted by JCB.
If you have any questions or concerns, please contact us through the Tribe Support Centre ticketing system [https://support.tribepayments.com].
Thank you for your understanding.
Tribe Operations Team
Posted Jul 09, 2025 - 09:11 UTC
This scheduled maintenance affected: Acquirer Processing (Payments processing).