We can confirm that services have been restored, and the impacted and delayed clearing files have been successfully sent out to the scheme. Following thorough monitoring, we have confirmed that systems are functioning as expected, and no further delays on new clearing files are expected. This incident is now considered resolved.
In case of impact, if there was any, each partner will be notified individually by their Customer Operations Manager, along with the root cause details, once the investigation is concluded.
Thank you for your patience and cooperation during this time.
Posted Nov 07, 2025 - 19:45 UTC
Identified
Dear Partners,
Please be informed that our investigation has confirmed that the impact affected the following areas: • Clearing and settlements delays (all schemes) • Chargeback import delays (all schemes) • SFTP uploads delays • Report generation delays
An immediate fix has already been applied, and our teams are now focusing on submitting the pending data to minimise the delay. Please note that transaction processing remains unaffected and continues to operate as expected.
We will keep monitoring the situation closely and share further updates as needed.
Thank you for your patience and understanding.
Posted Nov 07, 2025 - 09:08 UTC
Investigating
Dear Partners,
We are currently experiencing a delay in settlement processing. This issue is affecting settlement and clearing within the Acquirer Processing. Our technical teams are actively working to diagnose and resolve the issue as quickly as possible. We are closely monitoring the situation and will provide updates as new information becomes available.
Thank you for your patience and understanding.
Tribe Operations Team
Posted Nov 07, 2025 - 06:39 UTC
This incident affected: Acquirer Processing (Payments processing).