Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 04, 2025 - 03:00 UTC
Scheduled
Dear Customer,
We would like to inform you about a maintenance event scheduled by CENTROlink.
Maintenance Schedule: Start: 2025-09-04 03:00:00 UTC End: 2025-09-04 03:15:00 UTC
Expected Impact: During this period, SEPA Instant transactions will not be processed for both Bank and Wallet Products. Normal processing will resume promptly once the maintenance window has been completed.
Tribe will closely monitor all operations throughout this maintenance window to ensure service stability. In the event of any service disruptions, our teams are on standby and ready to respond promptly.
If you have any questions or concerns, please do not hesitate to contact us through the Tribe Support Centre.
Thank you for your understanding.
Best regards, Tribe Operations
Posted Sep 02, 2025 - 12:02 UTC
This scheduled maintenance affected: Bank Connect (Bank Payments processing) and Digital Banking (Payments processing, API).