Discover / Diners Club – Settlement Processing Delay

Incident Report for Tribe

Resolved

Dear Partners,

We would like to provide an update regarding the previously reported Discover settlement delay.

As of 03 February 2026, we have started receiving Discover / Diners Club clearing files. Based on this, the immediate impact on file delivery appears to be resolved, and we are closing the incident status at this time.

Please note that Discover has informed us that their technical teams are still investigating the root cause of the issue. Should any additional information become available that is relevant to your operations, we will share an update accordingly.

Thank you for your understanding.

Kind regards,
Tribe Operations Team
Posted Feb 05, 2026 - 14:19 UTC

Identified

Dear Partners,

We would like to inform you that Discover has reported a delay in settlement processing.

The issue began at approximately 00:32 GMT on 02 February 2026.

Discover’s technical teams are actively working on the resolution.

Expected Impact:
Discover / Diners Club clearing files may be processed later than usual. No additional impact has been communicated at this time.

Thank you for your understanding,
Tribe Operations Team
Posted Feb 03, 2026 - 07:44 UTC