We have received confirmation from Mastercard that the recent service disruption affecting their systems has been fully resolved as of 15 October 2025 at 18:17 UTC.
Normal clearing and settlement operations have resumed, and all related processes are functioning as expected.
Thank you for your patience and understanding.
Posted Oct 16, 2025 - 07:01 UTC
Identified
Dear Partners,
We have been informed of a service disruption on Mastercard’s side affecting the Mastercard File Express (MFE) platform, starting on 14 October 2025 at 23:10 UTC.
As a result, file processing and clearing activities may experience temporary delays.
We are monitoring the situation closely and will provide updates as soon as Mastercard resolves the issue.
Thank you for your understanding.
Posted Oct 15, 2025 - 07:08 UTC
This incident affected: Issuer Processing (Card Payments processing) and Acquirer Processing (Payments processing).